Notorious Notes

Song Factory

Forum

Installation Problem

Forum > Support > Installation Problem
bcarney 9/23/2010 12:05:20 PM
Using Vista Home Premium. What exactly is the .NET requirement? Does it have to be 5.1 as per installation message?

Looking forward to trying the programme.

Thanks
james 9/24/2010 1:36:12 PM
Hi bcarney,

SongFactory needs the Microsoft .Net Framework in order to run - it's a set of base libraries. The SongFactory installer checks if you have the required version installed and then asks to install it if you don't.

I'm not sure where the 5.1 message is being displayed - the highest version of .Net is 4, and I think (off the top of my head) that SongFactory uses and installs 3.5 (which will work fine alongside any other versions of .Net that your computer might have). Was the message you've seen displayed during the installation process?
james 9/24/2010 1:39:17 PM
I've just checked and the installer checks and installs (if needed) .NET 3.5 SP1 - hope that helps
bcarney 9/26/2010 6:13:14 PM
Without .NET 3.5 installed, the Songfactory installer pauses. At this point you need to install .NET 3.5. This proved unsuccessfull several times for reason unknown. However, I eventually succeeded in installing it and Songfactory installed successfully.

However, on restarting Windows and running SongFactory it crashed. The log reads:

Description:
Stopped working

Problem signature:
Problem Event Name: APPCRASH
Application Name: SongFactory.exe
Application Version: 1.1.3696.27279
Application Timestamp: 4b76c237
Fault Module Name: KERNEL32.dll
Fault Module Version: 6.0.6002.18005
Fault Module Timestamp: 49e037dd
Exception Code: e0434f4d
Exception Offset: 0003fbae
OS Version: 6.0.6002.2.2.0.768.3
Locale ID: 2057

If I keep failing to run it I will start another thread with this unless this is something you can advise on..
james 9/27/2010 8:38:32 AM
Hi bcarney,

I'm not sure why the .NET 3.5 install would have failed - it's usually pretty reliable. Were you connected to the internet when you tried to install? The .NET installer needs access to the Microsoft site to download things...

Thanks for posting the error log, but I'm afraid the error code is one of those frustrating ones that could be anything! If the application is presenting this message before it even loads then I suspect that it may be due to the problems you've experienced during install. (i.e. some library missing perhaps)

I'd recommend that you try uninstalling SongFactory and then re-installing it. That will force the installer to check again that all the required bits are fully installed. If something got missed or skipped during the current install then that could be causing the problem that you're experiencing.

Sorry for the problems you're having, and thanks for your patience - we haven't had many problems with the installer, so I'm afraid I can't suggest any other generic solutions that have solved other people's issues.

If the problem's still there, let me know and I'll see if there's anything else we can do to help.
DHDNSAM 4/21/2011 11:14:52 PM
I'm having a problem installing on my Windows 7 laptop, Message reads "The version of this file is not compatible with the version of Windows you're running. Check.....to see whether you need an x86 (32-bit) or x64 (64-bit) version of the program..." I'm running Windows 7 in 64-bit, but I've been able to install both 32 and 64 bit programs, so I don't understand. Any information would be greatly appreciated.
james 4/21/2011 11:41:14 PM
Hi there - thanks for the message - SongFactory should work fine on 64 bit machines...

We've spotted today that Microsoft have updated their DirectX installer and this has caused problems with our installer (which uses this), so I suspect that this could be causing the problem that you're experiencing.

Really sorry for that - I'm going to put a message up on our site now and we'll get the installer fixed as soon as we can.

I'll repost to this thread when it's fixed, to let you know.

Thanks for your patience